ports, bootstrap-pkgsrcでトラブったらageるスレ

=> どうみてもchecksum mismatchです。
=> 本当にありがとうございました。
*** Error code 1

Stop.
make: stopped in /usr/pkgsrc/vip/orz

>>2-10あたりに関連スレ、お約束など。

411名無しさん@お腹いっぱい。2012/05/06(日) 13:37:32.24
カードリーダーまわりの更新が来たけど、カードリーダーが使えなくなったw

412名無しさん@お腹いっぱい。2012/05/06(日) 14:05:48.69
usbconfigとかやったあとusbconfig -d 0.0 dump_device_descをやって
idVendorとidProductをuppercaseにしてiProductあたりと一緒に
コロン区切りでccid-1.4.6/readers/supported_readers.txtへ書いてから
ビルドで良いのか。

413名無しさん@お腹いっぱい。2012/05/06(日) 16:00:15.41
idVendorとidProductをupper caseにせずccid-1.4.6/readers/supported_readers.txtの
最後尾に書き足してからビルドするだけで動いた。

414名無しさん@お腹いっぱい。2012/05/16(水) 20:21:41.09
shinonome って、1983 無くなったのか

415名無しさん@お腹いっぱい。2012/05/16(水) 20:28:33.46
ImageMagick がダメだなぁ

FAIL: tests/validate-colorspace.sh

===========================================
1 of 49 tests failed
See ./test-suite.log
Please report to http://www.imagemagick.org
===========================================

=========================================
ImageMagick 6.7.6: ./test-suite.log
=========================================

1 of 49 tests failed.

.. contents:: :depth: 2

FAIL: tests/validate-colorspace.sh (exit: 127)
==============================================

./tests/validate-colorspace.sh: not found

416名無しさん@お腹いっぱい。2012/05/23(水) 20:20:08.79
お、ようやくmozc復活か

417名無しさん@お腹いっぱい。2012/05/25(金) 13:20:30.89
>>415 とは別の話だが ImageMagick-6.7.7.0 もおかしいな

あらかじめ

/usr/local/lib/ImageMagick-6.7.7/modules-Q16/{coders,filters}

作っとかないとインストールで止まる

418名無しさん@お腹いっぱい。2012/05/27(日) 10:48:57.94
kde-4.8.3 だけど、

・ghostscript-8 だと止まる。9 入れろ
・unzip-iconv だと止まる。unzip にしろ
・ja-teTeX だと止まる。teTeX にしろ
・動画のサムネイル関係で止まる。予め ffmpegthumbnailer 入れとけ

位でどうにかなった

419名無しさん@お腹いっぱい。2012/06/02(土) 06:54:50.21
www/gir-repository-webkit をインストールしようとすると、

make[2]: *** `WebKit-1.0.gir' に必要なターゲット `Gtk-2.0.gir' を make するルールがありません.  中止.

で止まるものの、そもそも私は、
なんでこの ports をインストールしようとしているんだったかな。

420名無しさん@お腹いっぱい。2012/06/08(金) 18:51:16.88
libvncserver が既に入ってる png を入れようとして止まるな

421名無しさん@お腹いっぱい。2012/06/11(月) 16:04:39.91
モクズ復活したのはいいけど、入力できなかったバージョンのどこかで
辞書がキムチに漬かってないか?w
接続助詞のつもりで「から」と入れてるのにカタカナに変換しやがる。

422名無しさん@お腹いっぱい。2012/06/18(月) 20:09:40.30
mozcが通らないんだけど、amd64だけこんな感じで何とかならん?

--- mozc-server.orig/Makefile 2012-06-10 18:37:13.000000000 +0900
+++ mozc-server/Makefile 2012-06-18 20:02:46.861076815 +0900
@@ -19,10 +19,12 @@
LIB_DEPENDS= curl.6:${PORTSDIR}/ftp/curl \
gtest.0:${PORTSDIR}/devel/googletest \
protobuf.7:${PORTSDIR}/devel/protobuf \
- zinnia.0:${PORTSDIR}/japanese/zinnia
+ zinnia.0:${PORTSDIR}/japanese/zinnia \
+ gtk-x11-2:${PORTSDIR}/x11-toolkits/gtk20
+
RUN_DEPENDS= xdg-open:${PORTSDIR}/devel/xdg-utils

-BROKEN= does not build
+#BROKEN= does not build

USE_BZIP2= yes
USE_GMAKE= yes
@@ -52,6 +54,10 @@
BROKEN= Does not compile: segfault
.endif

+.if ${ARCH} == "i386"
+BROKEN= Broken ports: reported by pointyhat
+.endif
+
.if defined(WITH_DEBUG_CODE)
BUILD_MODE= Debug
.else

423名無しさん@お腹いっぱい。2012/06/18(月) 20:51:31.88
wesnoth が日本語表示できなくなったな

424名無しさん@お腹いっぱい。2012/06/19(火) 00:05:49.28
作ったemacsを起動しようとすると
https://bugzilla.gnome.org/show_bug.cgi?id=676167
これ絡みのエラーで落ちるのがつらい。
ちょっとGCONFとDBUS Support をOFF にして作り直してみる。

425名無しさん@お腹いっぱい。2012/06/19(火) 01:11:48.46
>>419 は、他にも Soup-2.4.gir とか、いろいろと足りないものがあるようだ。
取り合えず、他のマシンの /usr/local/share/gir-1.0/ ディレクトリに有ったファイルを一部コピーして /www/webkit-gtk2 をインストールすることはできたが、

案の定、gimp は、png 関連で、まだ実行できなかった。
とりあえずシンボリックリンクで、どうにかしたけれど。

426名無しさん@お腹いっぱい。2012/07/12(木) 15:20:06.72
libskkがvalaが古くて作れないよ〜だって。

427名無しさん@お腹いっぱい。2012/07/13(金) 18:54:59.00
>>426
valaが入ってると古いことが問題になるだけで、
valaが入っていなければ問題が生じない。

428名無しさん@お腹いっぱい。2012/07/17(火) 22:22:05.32
ibusdakeappude-tosaretemokomaru

429名無しさん@お腹いっぱい。2012/07/20(金) 17:12:22.30
oggが

430名無しさん@お腹いっぱい。2012/09/06(木) 10:16:23.07
vlc の make中に segmentation fault

431名無しさん@お腹いっぱい。2012/09/09(日) 18:29:12.06
# portugrade -o security/libotr3 security/libotr

portupgrade だろ。UPDATING で間違ってどうするよ
あと、いつになったら mozc 関係マトモに安定するんだよ

** Listing the failed packages (-:ignored / *:skipped / !:failed)
! japanese/mozc-server (ja-mozc-server-1.5.1090.102_7) (distinfo incorrect)
! japanese/mozc-tool (ja-mozc-tool-1.5.1090.102_7) (distinfo incorrect)

432名無しさん@お腹いっぱい。2012/09/09(日) 18:56:18.38
>>431
5時間くらい前に訂正来てるじゃんと思ったら中がレガシーでワラタw

433名無しさん@お腹いっぱい。2012/09/10(月) 04:28:46.05
make NO_CHECKSUM=yes で
無理やり make したらリンクエラーw

434名無しさん@お腹いっぱい。2012/11/14(水) 13:06:41.68
portsをsubversionに移行した。
kernel(current)も作り直したらapacheが起動しなくなったので再ビルドしようと
apacheに依存するのを全部削除してapache22を再ビルドした。
portauditにapache22は脆弱性あるから/usr/portsを最新にしろといわれた。
svn update /usr/portsした
svn: not found


詰んだ

435名無しさん@お腹いっぱい。2012/11/14(水) 17:57:52.18
portsnapじゃあかんの?

436名無しさん@お腹いっぱい。2012/11/14(水) 23:22:35.30
pkg_add -r svn

437名無しさん@お腹いっぱい。2012/11/17(土) 17:41:02.60
>>434
最新にしたからといって対応済みのものが入手できるとは
限らんわけだが、とりあえず今のportsで
DISABLE_VULNERABILITIES=YES
でインストールしてから考えたので問題は無いと思う

438名無しさん@お腹いっぱい。2013/04/27(土) 12:28:27.13
mozc 関連をアップグレードしようとすると、glib だのも強制的に make し直すハメになるんだがウチだけか?

439名無しさん@お腹いっぱい。2013/04/27(土) 12:37:35.58
なぜかBUILD_DEPENDSになってるからglibやgtkというコマンドを持っていないと強制的にハマるw

440名無しさん@お腹いっぱい。2013/05/01(水) 15:41:23.78
大きい変更が加えられている最中であるせいか、
やらなくても支障のない変更はされないw

441名無しさん@お腹いっぱい。2013/05/06(月) 00:06:02.73
>>438
うちもハマったんで、ググッたら

ttp://www.dec.sakura.ne.jp/~junchoon/machine/freebsd.html

このサイトの人が解決策見つけてくれたみたい。うちの環境は8.3だし、
まだ試してないけど。やってみる価値はあるんじゃないか?

442名無しさん@お腹いっぱい。2013/05/06(月) 00:45:33.80
jakarta-commons-codec も同じ様におかしい気がする
なんか盛大に make しまくった挙句に失敗する

443名無しさん@お腹いっぱい。2013/05/10(金) 07:46:40.95
失敗なのでageでw

configでオプションを変更させるとdistfilesの数が変化するportで
すべてのdistfilesが落ちるオプション設定でmakesumをしていないから
特定のオプションが指定されているとextractできないというものがあるね。
今のnetpbmとか。

444名無しさん@お腹いっぱい。2013/05/10(金) 09:22:25.39
そりゃPRしろよ

445名無しさん@お腹いっぱい。2013/09/27(金) 16:13:28.53
pors-mgmt/portconfが使えなくなってる。bmakeになったのが原因?

446名無しさん@お腹いっぱい。2013/10/25(金) 11:42:20.63
なんだよこれ

/usr/local/lib/libR.so: undefined reference to `ucol_open_46'
/usr/local/lib/libR.so: undefined reference to `ucol_close_46'
/usr/local/lib/libR.so: undefined reference to `ucol_setAttribute_46'
/usr/local/lib/libR.so: undefined reference to `uiter_setUTF8_46'
/usr/local/lib/libR.so: undefined reference to `uloc_setDefault_46'
/usr/local/lib/libR.so: undefined reference to `ucol_strcollIter_46'
/usr/local/lib/libR.so: undefined reference to `ucol_setStrength_46'
collect2: ld returned 1 exit status

icu がいけてないのか
Rがバージョン決めうちの変な参照の仕方してるのか
良くしらないけど

447名無しさん@お腹いっぱい。2013/10/30(水) 15:18:55.39
なんか stage のせい?

ports build の際に下で一旦pkg化をしてから
インストールするらしいのだが,その pkg化で
細かいpathの違いでこける(親機では symlinkとかあって問題ない)ものが
結構あるみたいな印象
(FreeBSD-8-stable の7月頃のものと最新ports)

例:
tar: could not chdir to '/usr/obj/usr/ports/x11-toolkits/linux-f10-pango/work/stage/usr/compat/linux

448名無しさん@お腹いっぱい。2014/08/24(日) 00:39:01.72
interix (Windows SFU/SUA) のpkgsrc使っている人いる?
久しぶりに使おうとFTPのぞいたら、フォルダごと消えてた。割と貴重なバイナリがたくさんあったのに。

449名無しさん@お腹いっぱい。2014/08/24(日) 06:34:54.89
>>447
@cwdでディレクトリを変更したときの挙動がpkgngとそれ以前で若干違うせい。

450名無しさん@お腹いっぱい。2014/12/07(日) 11:19:21.61
pkgsrc 最近はInterixじゃ動かないね。

OpenSSL必須なのか tnftp のビルドで躓く。
これサポートしてるって言うけど、詰んでる状態だな

SSL要らん古いtnftpとか探したけど見つからんし、
OpenSSLはいつまでもInterix未サポートだから、進まんわ。

素直にNetBSD使うから別にいいんだけどさ。
でも、たまに変な環境で遊んでみたくなるんだよな

451名無しさん@お腹いっぱい。2014/12/07(日) 11:25:10.62
詰んだ詰んだ
ぴょんぴょん待ち

452名無しさん@お腹いっぱい。2014/12/12(金) 23:21:00.17
php-mbstringが動かん。
php.iniでmbstring.soのコメントを外してもphpinfo()に出てこない。
5.5.17、5.4.33を試したがダメ。
pkgsrc-2014Q3、OS X 10.9.5、Xcode-5.1.1
Q1ぐらいでは動いていた気がするので戻してみるか……

453名無しさん@お腹いっぱい。2014/12/24(水) 21:23:37.98
ziproxy使おうとおもったら、いつの間にかportsからいなくなっていた。

4544522014/12/29(月) 19:35:57.11
OSがMavericksでXCode 6にしたらコンパイルできないのがあったので
XCode 5.1.1にしていたが、両者でビルドしたバイナリーが混じっていたのが
まずかったようだ。
bootstrapからやり直したらOKになった。

455名無しさん@お腹いっぱい。2016/07/10(日) 23:03:15.62
pkgsrcでlibressl入れてもopensshで使えない

456名無しさん@お腹いっぱい。2016/07/10(日) 23:05:10.54
Solaris 10でpkgsrcのgroff、makeできるけどmake installできない。

https://mail-index.netbsd.org/pkgsrc-bugs/2015/07/13/msg057288.html
pkg_create: can't stat が出るので、このPRに似ている

457名無しさん@お腹いっぱい。2016/09/04(日) 15:11:15.25

458名無しさん@お腹いっぱい。2017/12/29(金) 10:55:47.92
誰でも簡単にパソコン1台で稼げる方法など
参考までに、
⇒ 『宮本のゴウリエセレレ』 というブログで見ることができるらしいです。

グーグル検索⇒『宮本のゴウリエセレレ』

N71Y7ER8Y6

459名無しさん@お腹いっぱい。2018/02/14(水) 10:25:08.34
☆ 日本の、改憲をしましょう。現在、衆議員と参議院の両院で、
改憲議員が3分の2を超えております。『憲法改正国民投票法』、
でググってみてください。国会の発議はすでに可能です。
平和は勝ち取るものです。お願い致します。☆☆

460名無しさん@お腹いっぱい。2018/04/22(日) 21:49:19.93
NetBSD 7.1 amd64
pkgsrc 2017Q1

/usr/pkgsrc/graphics/blender
を make install したのですが、エラーになってしまいました。

Scanning dependencies of target blender
[100%] Building C object source/creator/CMakeFiles/blender.dir/creator.c.o
[100%] Building C object source/creator/CMakeFiles/blender.dir/buildinfo.c.o
[100%] Linking CXX executable ../../bin/blender
ld: cannot find -ljemalloc
ld: cannot find -ljemalloc
source/creator/CMakeFiles/blender.dir/build.make:294: recipe for target 'bin/blender' failed
gmake[2]: *** [bin/blender] Error 1
CMakeFiles/Makefile2:7647: recipe for target 'source/creator/CMakeFiles/blender.dir/all' failed
gmake[1]: *** [source/creator/CMakeFiles/blender.dir/all] Error 2
Makefile:160: recipe for target 'all' failed
gmake: *** [all] Error 2
*** Error code 2

Stop.
make[1]: stopped in /usr/pkgsrc/graphics/blender
*** Error code 1

Stop.
make: stopped in /usr/pkgsrc/graphics/blender

4614602018/04/22(日) 21:51:38.53
/usr/pkg/lib/
以下に
libjemalloc.a
libjemalloc.so@
libjemalloc.so.2*
があり、ライブラリはあると思うのですが・・・
どうすればinstall可能でしょうか?

新着レスの表示
レスを投稿する