【初心者歓迎】総合質問スレッド-85-【ダウソNG】 [無断転載禁止]©2ch.net

1名無しさん@編集中 (ワッチョイ 62ea-qt4g)2017/07/15(土) 18:39:41.03ID:tPrILabP0
教えて君は初心者に非ず。既に同じ質問がないかgoogleやスレ内を検索するように。
よくある質問や該当ソフトのスレのテンプレを読んでから書き込もう
2ちゃんねるスレッド検索 http://find.2ch.net/

もっと優しく教えて欲しい人、教えたい人、テンプレを読むのが嫌な人は
教えて!goo http://oshiete.goo.ne.jp/

前スレ
【初心者歓迎】総合質問スレッド-83-【ダウソNG】
http://echo.2ch.net/test/read.cgi/avi/1454932012/

よくある質問・関連リンク等は、>>1-6を参照

300名無しさん@編集中 (ワッチョイ 57ec-9jjH)2018/04/20(金) 23:59:55.37ID:lhQxdgpG0
>>299
問題ないようだけど。x264のパラメータが省略されてるのでそこに原因があるなら知らんが。
二度手間になるから、質問や検証依頼をする場合は省略すべきじゃないよ。
x264のログや出力ファイルのMediaInfo情報とかもあるといいかもね。

以下コメント。
1.YV24(4:4:4)にしてる理由は何?(何か意図があるなら別にいいんだけど)
2.その設定だとf3kdbを使う意味が全く無い気がする。
  デバンドもディザリングもせず8->16bit変換してるだけのような・・・。
  8bitのままx264に渡した場合と結果が変わらないんじゃないか?
3.264出力してからmuxerでmp4にするんじゃなく、x264で直接mp4を吐いた方が良いのでは?
4.jpsdr版(tMod)のx264を使う理由は何?
  現在のtModは変態コミットになってるし、できれば8/10bit統合した本家x264を使った方が良いと思うけど。
5.Avisynth+が古すぎ。更新した方がいいと思うよ。
  高深度色空間もサポートしてるから、わざわざavs2pipemod -rawvideoで渡したりしなくても
  高深度のavs(YUV444P16等)をそのままx264に渡せるから楽。

301名無しさん@編集中 (ワッチョイ 0bb3-2WsW)2018/04/21(土) 01:33:47.12ID:lPYsC1Qd0
>>300 1〜4について
1.444にしたのはたまたまです(420、422もバッチを作っています)
3.は3-4年前くらいにどこかのBlogで「x265」の出力を見てそれで「l-smash」を覚えた為です(それが265出力していたため)
4.はその更に前から使っていたためです、その前は[ http://x264.nl/x264/ ]です
x264.nlからの配布が止まった後たまたま次がtModになって以後使っています、tModの使用は天山牛棚からだった気もします
出来れば細かくパラメータを変化させてみたいと思っているのでtModを継続使用したいと思っています

※AviSynth+はMTにしていません、x64はインストールしていますが動かしているのはまだx86のままです
バッチファイルもAviSynth2.6.1Alpha1(x86)用を使用しています

302名無しさん@編集中 (ワッチョイ 0bb3-2WsW)2018/04/21(土) 01:36:29.41ID:lPYsC1Qd0
2.省略したx264(コロコロ変化させていますが今回は↓です)
--level 4.1 --crf 20 --aq-mode 2 --aq-strength 0.8 --psy-rd 0.6:0.0 --ipratio 1.4 --pbratio 1.3 --qcomp 0.60
--qpmin 12 --qpmax 69 --qpstep 8 --scenecut 60 --min-keyint 23 --keyint 300 --bframes 6 --b-adapt 2 --ref 9 --weightp 2 --direct auto
--me umh --subme 9 --merange 32 --trellis 2 --deblock 0:0 --threads 0 --no-mbtree --vbv-maxrate 62500 --vbv-bufsize 50000 --rc-lookahead 60 --no-opts
自分で入れたのはこれだけです(大半は気分で変えます、--no-optsも気分で入れているだけです)
どこにでもある程度のパラメータだったので省略しました

303名無しさん@編集中 (ワッチョイ 57ec-9jjH)2018/04/21(土) 03:52:44.91ID:yoTOjTHL0
tModってのはx264本家に無い機能(パッチ)を盛り込んだり、オプション機能を有効にしてビルドしたバイナリだよ。
それらの機能を使いたい人が自己責任で使うものであって、そうでないなら使う理由はない。
出てきた話の中でtModにしかないものって、--no-optだけだね。
x264本家はr2893で8bit用と10bit用のバイナリが統合されて1つになったけど、
tModはパッチとかの絡みで分離したままになっており、x264本家とはやや乖離した状態になっている。
無難に使うならrigaya氏のバイナリがいいとは思うけど、その他については不便なままでいいなら特に言うことはない。

>>302のオプションをつけても特に問題は無かったし、
 ・x264のログ(ちゃんと見たんだろうか)
 ・出力ファイルをMediaInfoのテキストモードで調べた結果
 ・「画像が真っ暗」ってどんな再生ソフトで確認したの?
といった情報をちゃんと出したほうがいいと思うよ。

あとうちはWin10FCUでAvisynth+ r2508(ちょっと古い)を使ってるのでWin7や異なるAvisynthでどうなるかはわからん。

304名無しさん@編集中 (ワッチョイ 0bb3-2WsW)2018/04/21(土) 07:14:07.21ID:lPYsC1Qd0
再生ソフトはMPC-HCでした
失礼しました、MPC-BEで正しく再生できました(BEのみmadVR追加しただけ)
メインにHCを使っていたのはかなり前にAVS、TS、ffdshowでの再生を行っていたためです
お騒がせしましたm(__)m

305名無しさん@編集中 (ワッチョイ 0bb3-2WsW)2018/04/21(土) 09:22:45.27ID:lPYsC1Qd0
追記(MPC-HCのバージョン)
MPC-HC
------
Build information:
Version: 1.7.13 (e37826845)
Compiler: MSVC v19.00.24215.01 (SSE2)
Build date: Jul 16 2017 18:41:51
LAV Filters:
LAV Splitter: 0.70.2.1
LAV Video: 0.70.2.1
LAV Audio: 0.70.2.1
FFmpeg compiler: MinGW-w64 GCC 7.1.0
Operating system:
Name: Windows NT 6.1 (build 7601, Service Pack 1)
Version: 6.1 (64-bit)
Hardware:
CPU: Intel(R) Core(TM) i7 CPU 870 @ 2.93GHz
GPU: NVIDIA GeForce GTS 450 (driver version: 23.21.13.9077)

306名無しさん@編集中 (ワッチョイ e3ec-9jjH)2018/04/21(土) 14:47:17.37ID:vIk2JOlP0
>>304
r2893でエンコしたものはMPC-HCでも再生できてたんじゃないの?
r2901に変えただけで再生できなくなったんだとしたら、それはそれで異常な事態というか
tModのr2901に問題があるかもしれないってことなんだけど。

もう1つ気になってるのはL-SMASHも古いまま使ってるんじゃないかって点だが・・・。
muxer.exe --versionでバージョンが確認できるけど、いつのを使ってるんだ?
最新はr1470だから、更新しといたほうがいいと思うよ。

307名無しさん@編集中 (ワッチョイ 0bb3-2WsW)2018/04/21(土) 15:03:09.08ID:lPYsC1Qd0
確かにr2893での再生は問題ありませんでした
>muxer.exe
最近は更新を怠っていました、r1453でしたので更新しておきます
その上で再度確認してみます

308名無しさん@編集中 (ワッチョイ 0bb3-2WsW)2018/04/21(土) 15:44:43.35ID:lPYsC1Qd0
l-smashを入れ替えてテストしましたが変化なしです
画像は・・・(MPC-HC)
https://i.imgur.com/jpSLPsD.png
MPC-BEだと普通に画像が出ます(そちらはUpしません、画像は数日で削除します)

309名無しさん@編集中 (ワッチョイ e3ec-9jjH)2018/04/21(土) 15:45:50.41ID:vIk2JOlP0
ついでにrigaya氏やVideoLANのr2901バイナリも使って比較してみるといいかもね。
オプションは--no-optsを外して--output-depth 10をつけるだけでいい。

rigaya氏のバイナリはブログ右下のx264から。
VideoLANのバイナリは以下のURLから。
 http://download.videolan.org/pub/videolan/x264/binaries/win64/

tModのr2901だけおかしいなら、tModの問題ということになる。

310名無しさん@編集中 (ワッチョイ e3ec-9jjH)2018/04/21(土) 16:14:36.82ID:vIk2JOlP0
なおうちで試した限りでは、tModのr2901でエンコしたものでも、
同じバージョンのMPC-HC(x64版)の内臓デコーダー+EVR-CPで問題なく再生できる。
ソースは以下のavs。

ColorBarsHD(1280,720).Trim(0,100)
ShowFrameNumber(x=20,y=20)
f3kdb(range=0, Y=48, Cb=0, Cr=0, grainY=0, grainC=0, keep_tv_range=true, input_mode=0, input_depth=8, output_mode=2, output_depth=16)

MPC-HCの内臓ビデオデコーダー(LAV)のHardware AccelerationがNone以外になってるならNoneにして検証してみることも勧める。
(4:4:4ではDXVA等は効かないと思うが念のため)

311名無しさん@編集中 (ワッチョイ 0bb3-2WsW)2018/04/21(土) 23:43:15.79ID:lPYsC1Qd0
>>309
rigaya氏のr2901はMPC-HCでも問題なく再生しました
まさかとは思ったのでWinthread版r2901を使ってエンコしてみたらこちらも問題なく再生しました
確実性は本家ですね、aqもラクですし
tModを使い続けたのはaq関連のパラメータを試していたためでもあります(aq3は設定はできたもののaq2は設定さえ出来ず困り果ててました)

312名無しさん@編集中 (ワッチョイ 0bb3-2WsW)2018/04/22(日) 00:00:06.36ID:hFsX9Frn0
>>311 訂正
tModのr2901はやはり再生できていませんでした

313名無しさん@編集中 (ワッチョイ e3ec-9jjH)2018/04/22(日) 00:07:57.97ID:KkJbuU170
>>312
そういえば書き忘れてたけど、こちらでは>>299のうち、%timelineeditor%のとこは実行してない。
>>310のavsを書かれてたとおりのコマンドで264出力してmuxerでmp4にするところまで。
現象の差に関係しているかは不明。

314名無しさん@編集中 (ワッチョイ 0bb3-2WsW)2018/04/22(日) 01:39:51.04ID:hFsX9Frn0
VLCがあるのを思い出したので試しに再生してみたら現象はtModのr2901と同じ
出力をmp4にしても同じです
tModのr2893はOK、r2901はBEのみOK(HCでも8bit・x264は普通に見れました)
後日時間を見てHi10p、Hi422の確認をしておきます

315名無しさん@編集中 (ワッチョイ 0bb3-2WsW)2018/04/22(日) 12:02:30.20ID:hFsX9Frn0
>>315の続き
tMod・r2901、MPC-HC
Hi10p(yuv420p10):OK
Hi422(yuv422i10):OK
Hi444(yuv444p10):NG
MPC-BEは全てOK、tMod・r2893もMPC-HC、BEでの再生OK,
本家も問題なし、OSかAviSynth+が古いかだとしばらくは対応できません

316名無しさん@編集中 (ワッチョイ 471b-CtcI)2018/04/22(日) 18:43:15.90ID:XhsfTls80
ffmpegを使っていてCPU使用率が60%くらいまでしか上がらないのですが
100%まで使用することってできないのでしょうか?
handbrakeなら100%使うことができるのですが・・・

317名無しさん@編集中 (ワッチョイ 1ad2-mheP)2018/04/23(月) 08:03:00.93ID:R80RJNiu0
>>316
コマンドくらい書かないと誰も分からない

318316 (ワッチョイ 471b-CtcI)2018/04/23(月) 21:55:04.10ID:Tx26GsRB0
>>317
至って普通のこういうコードです

"D:\Program Files2\ffmpeg\bin\ffmpeg.exe" -y -i "E:\test.mp4" -vcodec libx264 -preset veryslow -crf 20 -acodec copy "E:\test.mkv"


CPUにCore i7 extremeを使っており、
コアが10個がありますが、
リソースモニターを見ると全てのコア・スレッドは同時に使用できているのですが
いずれも使用率が50%くらいまでしか上がりません。
ffmpegの仕様上このようなコア数には対応していないのでしょうか?

handbrakeならできるので
ffmpegでもできると思うのですが・・

319名無しさん@編集中 (ワッチョイ 471b-CtcI)2018/04/23(月) 22:01:46.72ID:Tx26GsRB0
"D:\Program Files2\ffmpeg\bin\ffmpeg.exe" -y -i "E:\test.mp4" -vcodec libx264 -preset veryslow -crf 20 -acodec copy -threads 10000 "E:\test.mkv"

というように、 -threadsにでかい値を入れると
100%近くまで上がるようになりました
なぜデフォルトだと50%くらいまでしか上がらないのでしょうか?
 

320名無しさん@編集中 (ワッチョイ 36e7-QgoH)2018/04/24(火) 09:45:58.24ID:+GKuK/3l0
threadsにCPUコア数以上の値を入れてないから

321名無しさん@編集中 (ワッチョイ aa39-FFve)2018/04/25(水) 21:44:50.52ID:DhQREW5G0
>>246
ビデオを作成する - Windows Help
ttps://support.microsoft.com/ja-jp/help/17205/windows-10-create-videos
WindowsMovieMakerの後継ソフトが出てることに、いまごろ気づいたので貼る
最近のWin10なら標準で入ってるっぽい

322名無しさん@編集中 (ワッチョイ 5b7f-jMXy)2018/04/27(金) 11:41:13.11ID:PLvUpLvx0
言葉の使い方で少し悩んでいます

H.264からH.264へ変換するときはAVC動画からAVCへ変換と言い換える事があるように
UtVideo YUV420 BT 601 VCMで作ったAVIをH.264へ変換するときはAVIからAVCへ変換 という表現でいいのでしょうか?
それともUtVideo YUV420 BT 601からAVCへ変換という表現の方が適切でしょうか?
言葉の使い方で悩んでいます

323名無しさん@編集中 (ワントンキン MMd3-MzOo)2018/04/27(金) 12:07:21.97ID:OLJbO2mEM
どう言おうが自由だけど誤解を生まないのは後者じゃね
前者はコンテナとコーデックが混在してる

324名無しさん@編集中 (ワッチョイ 5b7f-jMXy)2018/04/27(金) 13:12:11.58ID:PLvUpLvx0
>>323
ありがとうございます 誤解を招かない方がいいですね

325名無しさん@編集中 (ワッチョイ 9397-s8TH)2018/04/27(金) 13:38:32.42ID:UE0uIVeq0
ts2aacについての質問なのですが、
↓の数字は何を示しているのでしょうか readmeには説明ありませんでした
https://i.imgur.com/yXgD7m5.jpg

326名無しさん@編集中 (ワッチョイ d9ec-luqG)2018/04/27(金) 17:09:40.51ID:yreiPjtm0
>>322 >>324
コンテナとコーデックを両方ちゃんと明記したほうがいいと思うよ。

327名無しさん@編集中 (ワッチョイ 5b7f-jMXy)2018/04/27(金) 18:18:29.72ID:PLvUpLvx0
コーデック UtVideo YUV420 BT 601 VCM コンテナaviを
コーデック H.264 コンテナmp4へ変換する
みたいな表現が一番正確で誤解招かないという事になりますか?

328名無しさん@編集中 (ワッチョイWW c906-MzOo)2018/04/27(金) 18:25:27.06ID:DQ6LXP0N0
厳密に合わせるなら色解像度と色域も変換前後で言うといいけど
それは状況によるかな
どういうときに言うかで必要な情報は変わってくるでしょ
まあ多いに越したことはないけど

329名無しさん@編集中 (ワッチョイ 5b7f-jMXy)2018/04/27(金) 18:34:23.28ID:PLvUpLvx0
ありがとう参考になりました

330名無しさん@編集中 (ワッチョイWW 878a-TCRo)2018/05/03(木) 18:15:06.49ID:eD+lCO2L0
この動画の14秒〜のとこの逆光っぽくホワイトアウトするのってどうしたらできる?なんかエフェクトに名前とかついてたら教えてほしい

https://youtu.be/Zij9HJUVw1U&t=0m14s

331名無しさん@編集中 (ワッチョイ 0bec-XJxX)2018/05/03(木) 20:24:58.02ID:C8kGkolD0
目に悪すぎるからすぐ閉じたわ・・・

332名無しさん@編集中 (ワッチョイ a306-HSUF)2018/05/06(日) 19:49:14.28ID:hxU/Lc130
DVDからVOBを抜き出せたら、
そのVOBが完全な無劣化動画ということですよね
使用するリッピングソフトなどによって違いとかないんですか?

333名無しさん@編集中 (ワッチョイ fa7f-pRpi)2018/05/06(日) 22:56:22.29ID:T8Cf4wMS0
初心者ですみませんが質問させてください
aviutlで動画に○とか△とか→みたいなものを
手書きで入れたいのですが、どうしたらいいのでしょうか?

334名無しさん@編集中 (ワッチョイ bfec-XJxX)2018/05/06(日) 23:00:29.00ID:JjcNkUrQ0
手書きしたPNG画像を合成すればいいんじゃね。

335名無しさん@編集中 (ワッチョイ fa7f-pRpi)2018/05/07(月) 00:44:52.35ID:8jNSbDm80
返信ありがとうございます。
質問がおかしかったようで、失礼しました。

要するにこのJingというソフトの静止画でできることを
動画でもやりたかったのですが、こういうのは無理なんでしょうか

https://forest.watch.impress.co.jp/article/2007/08/09/jing.html

「さらに、静止画をキャプチャーした場合は、画像内へ矢印、枠線、テキスト、
マーカーを任意の色で描き込むこともできる。
たとえば、強調したい場所を赤色で囲うなどすれば、
アプリケーションのヘルプファイル作りにも役立つ。 」

336名無しさん@編集中 (ワッチョイ 0ad2-7y2u)2018/05/07(月) 04:46:50.94ID:/spguxHh0
>>333
ググったらこんなの出てきたけどどうだろ


Aviutlプラグイン「手書きツール」α版 : プログ
http://aoytsk.blog.jp/aviutl/1985306.html

337名無しさん@編集中 (ワッチョイ fa7f-pRpi)2018/05/07(月) 07:01:24.19ID:8jNSbDm80
おお〜ありがとうございます。
まさにこういうのを求めていました

338名無しさん@編集中 (ワッチョイ 53b3-W8se)2018/05/08(火) 21:44:07.45ID:L2Joau/O0
質問です、今まではavs2pipemodを使ってx264(x64)を使っていましたが
パイプ無しでエンコしてみようと思いバッチを作って試したらAvsPmodで見るのと同じ長い画像になってしまいました
何か足りてないと思うのでご教示お願いします
<AVS>
LWLibavVideoSource
Trim(0,100)
Its
Spline36Resize(1280,720)
ConvertToYV12()
f3kdb(range=1, Y=56, Cb=10, Cr=10, grainY=0, grainC=0, keep_tv_range=true, input_mode=0,input_depth=8, output_mode=2, output_depth=16)
<x264> x264 core 155 r2901M 7d0ff22
x264_x64 --profile high10 --preset Medium <option> --fps 30000/1001 --input-res 1280x720 --input-range tv --range tv --thread-input --input-csp i420 --output-csp i420 --input-depth 16 --output-depth 10 -o out.mp4 in.avs

339名無しさん@編集中 (ワッチョイ 53b3-W8se)2018/05/08(火) 21:47:53.00ID:L2Joau/O0
>>338の続き
<x264のその他>※mediainfo
cabac=1 / ref=9 / deblock=1:-1:-2 / analyse=0x3:0x113 / me=umh / subme=9 / psy=1 / psy_rd=0.60:0.00 / mixed_ref=1 / me_range=32 /
chroma_me=1 / trellis=2 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=-2 / threads=12 / lookahead_threads=1 /
sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / bframes=6 / b_pyramid=2 / b_adapt=2 / b_bias=0 /
direct=3 / weightb=1 / open_gop=0 / weightp=2 / keyint=250 / keyint_min=23 / scenecut=60 / intra_refresh=0 / rc_lookahead=60 / rc=crf / mbtree=0 / crf=23.0 /
qcomp=0.60 / qpmin=10 / qpmax=69 / qpstep=6 / vbv_maxrate=30000 / vbv_bufsize=30000 / crf_max=0.0 / nal_hrd=none / filler=0 / ip_ratio=1.40 /
pb_ratio=1.30 / aq=1:0.60
・幅 : 2 560 ピクセル
・高さ : 720 ピクセル

340名無しさん@編集中 (ワッチョイ 53b3-W8se)2018/05/08(火) 21:49:00.50ID:L2Joau/O0
>>339の続き
<ログ、気になる部分>
avs [info]: 2560x720 0:0 @ 30001/1001
x264 [warring]: DPB size (9 frames, 64800 mbs) > level limit (4 frames, 32768 mbs)
x264 [info]: using cpu capabilities: MMX2 SSE2Fast SSE3 SSE4.2
x264 [info]: profile High 10, level 4.1, 4:2:0 10-bit

何故、2560x720になってしまうのか?この点を改善できればと思うのですが・・・

341名無しさん@編集中 (ワッチョイ 0ad2-7y2u)2018/05/09(水) 11:29:06.60ID:V9KjH4Zd0
>>338
Avisynthは本来8bitしかサポートしてないから16bitのピクセルを表現するときに8bitを2ピクセル並べて8+8=16みたいな感じにする
エンコーダーにデータを渡す時はそういう形式だと明示して渡さないとおかしくなるって話だと思う

High bit-depth Support with Avisynth - Avisynth wiki
http://avisynth.nl/index.php/High_bit-depth_Support_with_Avisynth

342名無しさん@編集中 (ワッチョイ bfec-XJxX)2018/05/09(水) 15:23:04.24ID:uSg4ETOb0
>>338
●Avisynthで高深度(High Bit Depth)を扱う方式には以下の2つがある。
  A.Stack16方式(stacked形式(縦2倍) / interleaved形式(横2倍))
  B.Avisynth+ r2290以降の高深度色空間(YUV420P16等)

●x264のavs入力は、Bの一部の高深度色空間のみ対応している。
 Aの高深度avsをx264で直接読むことはできない。
  (tModではパッチによりAを扱えた気がするが、今のtModは非推奨なのでここでは無視する)

●A形式の高深度avsをx264でエンコードする方法は以下の2つ。
  A1.avs2pipemod -rawvideoを使ってraw形式でパイプで渡す
  A2.avs4x26xで--input-depthを指定して高深度avsを渡す
 (A2の場合は--input-res/--fps/--frames/--input-cspを指定する必要が無いので、A2の方が楽。)

●B形式の高深度avsをx264でエンコードする方法は以下の2つ。
  B1.x264が対応している高深度色空間(YUV420P16等)の場合はx264に高深度avsを直接渡せる
  B2.avs2pipemodやffmpegを使って、高深度Y4M形式でパイプで渡す(rawでもいいがY4Mの方が楽)

343名無しさん@編集中 (ワッチョイ bfec-XJxX)2018/05/09(水) 15:25:18.74ID:uSg4ETOb0
>>338
>>338のavsは、AのStack16方式のinterleaved形式の16bit深度。
 Avisynth+ r2290以降を使っているのであれば、f3kdbの行の後に
  ConvertFromDoubleWidth(16)
 をつければB形式のYUV420P16の高深度avsにすることができ、x264に直接渡せる。
 (ただしYUV420P16はAvsPmodでそのままプレビューすることができない。
  プレビューしたい時のみ
    info().ConvertBits(16).ConvertToRGB48(matrix="Rec709").ConvertBits(8)
  をつけるといった対応が必要。)

●avsをA形式のままにするならA2のavs4x26xを使うことを推奨。
 avsをB形式のYUV420P16にするならB1でx264に直接avsを渡せばよい。

●--input-res/--fps/--frames/--input-cspはx264にraw形式で渡す場合のみ必要。
 avsやY4Mで渡す場合にはこれらの情報が含まれてるので、指定する必要はない。

344名無しさん@編集中 (ワッチョイ 53b3-W8se)2018/05/09(水) 21:09:57.31ID:WT8hB9M+0
>>341-343
わかりやすくてとてもありがたいです、ありがとうございます
r1576ではダメなんですね、r2290以降でないと・・・
r2294(x86)でtxt60mcHybrid/ivtc_txt60mcを使ったらすさまじく重くなったので(同じエンコで30分近く遅くなった)r1576を使っていましたが
切り替えてみるしかなさそうですね
(タイプしながら)
切り替える前にr1576とavs4x26x(x64)でエンコしてみたらtModではフレーム表示の度に改行してしまうのでダメなようです
(x264 core 155 r2901M 7d0ff22は問題無し)
※tMod稼動時は--output-depth 10は外してます(エラーになりますからあったら動きませんが)

345名無しさん@編集中 (ワッチョイ 85ec-k37M)2018/05/10(木) 11:51:57.79ID:C8Wcj3xB0
>>344
> 切り替える前にr1576とavs4x26x(x64)でエンコしてみたら
> tModではフレーム表示の度に改行してしまうのでダメなようです

それは別にダメってことじゃないし、Avisynth+ r1576やavs4x26xやtModに問題があるわけでもない。
tModはパッチによって進捗表示の内容が増やされてるから、表示幅が足りなくて改行されてるだけ。
コマンドプロンプトのウィンドウ幅を広げてやれば済む話。(r2901Mだってウィンドウ幅を狭めれば改行する)

通常(r2901M)の進捗表示
[9.1%] 1/11 frames, 9.43 fps, 290.18 kb/s, eta 0:00:01

tModの進捗表示
[9.1%] 1/11 frames, 8.929 fps, 291.57 kb/s, 35.59 KB, eta 0:00:01, est.size 391.51 KB

346名無しさん@編集中 (ワッチョイ 55b3-QSx/)2018/05/10(木) 19:30:09.32ID:LuxNfDVQ0
>>345
tmodとavs4x264.exeを使った時から下記のようにズラズラ出てしまうので相性が悪いのかと思ってます
AviSynth2.6MTからで別にエラーは出ていません
[1.2%] 1/80 frames, 0.109 fps, 10232 kb/s, 41.68 KB, eta 0:12:04, est.size 3.26
[5.0%] 4/80 frames, 0.418 fps, 3373.1 kb/s, 54.96 KB, eta 0:03:01, est.size 1.07
[12.5%] 10/80 frames, 1.016 fps, 1839.0 kb/s, 74.90 KB, eta 0:01:08, est.size 59

これがkModや本家なら改行せず上書き表示してくれます
なのでtModのパイプはavs2pipemod.exeにしています
エラーでも出ていればとも思いますが・・・
OSだったりすればどうしようもありません、あえてWindows7を継続使用を選んだので・・・
x264スレ、ほしいかもしれませんね、1ヶ月書き込みが無かったときにdat落ちしたようです

347名無しさん@編集中 (ワッチョイ 23ec-k37M)2018/05/10(木) 20:31:20.05ID:T5uN1Trq0
>>346
コマンドプロンプトのウィンドウ幅を変えろと言ってるんだが、聞く耳持たずに相性が悪いと決めつけるのか?
avs4x26xを使おうがavs2pipemodを使おうが関係ないと思うんだが。

348名無しさん@編集中 (ワッチョイ 55b3-QSx/)2018/05/10(木) 21:27:38.88ID:LuxNfDVQ0
改行と書いたのがまずかったですか?
横に広げようとしても受け付けません(縦は受け付けますが・・・)
書いたとおり次から次へと書かれていくのでコマンドプロンプトはあっという間に埋め尽くされます
avs2pipemodはそれがありません(あくまでtModの場合です、今回の質問自体はあくまで「x264 core 155 r2901M 7d0ff22 」使用時です)
その報告を書いただけです(別に無視したわけではないです)

avs4x26xを使う方法を使うことになる気がします、delogomod.dllがx86しか所持していないためです
(制作者さんのdelogomod0009.zipには2ケースありましたがどちらもx86)
Avisynthを絶讃ιょぅょ Part32
https://mevius.5ch.net/test/read.cgi/avi/1486535501/374
で配布されたx64版を気付きませんでした(多分1、2日程度の短期間配布だったはず)

349名無しさん@編集中 (ワッチョイ 4339-Jy5O)2018/05/10(木) 22:58:55.88ID:sDkoczmH0
>>348
> 横に広げようとしても受け付けません
マウスでドラッグしても広がらないよ

コマンドプロンプトのコンソール設定の変更
http://www.atmarkit.co.jp/ait/articles/1502/13/news147.html#setting
レイアウトの設定
http://www.atmarkit.co.jp/ait/articles/1502/13/news147.html#layoutsetting

350名無しさん@編集中 (ワッチョイ 55b3-QSx/)2018/05/10(木) 23:40:02.17ID:LuxNfDVQ0
>>349
長いこと触って来ましたが知りませんでした、ありがとうございますm(_ _)m

新着レスの表示
レスを投稿する